Archlinux-Zwischenstand: Alles muß ich selber machen!

Wie ich im letzten Post schon erwähnt habe, hat mein Archlinux den fatalen LMDE-Blackscreen überlebt. Was ich zum Anlaß genommen habe, mal wieder ein wenig daran rumzubasteln.

Was sich in der Titelzeile nach einem Stoßseufzer anhört, ist nur halb einer. Ja, es ist ungewohnt, mein System von Hand zusammenlöten zu müssen. Es ist verdammt unbequem und macht Arbeit. Deshalb mache ich das ja als Bastelsystem und Stückchen für Stückchen.

Es ist auch eine Chance, ein Systemverhalten, das ich bisher als gegeben hingenommen habe, zu überdenken: Ist das für mich sinnvoll und wünschenswert? Oder möchte ich das anders haben? Es ist eine Chance, mein System genau so zusammenzuschneidern, wie ich das haben will.

Ein Problem, mit dem ich mich z.B. herumschlage, ist, daß in meinem Rechner zwei Ethernet-Schnittstellen stecken (weil die am Mainboard nämlich kaputt ist). Beim Boot werden den Ethernet-Schnittstellen die Namen zufällig zugewiesen – was einmal eth0 ist, ist also beim nächsten Boot eth1. Der network-Daemon versucht aber über genau die Schnittstelle die Verbindung herzustellen, die in der rc.conf angegeben ist, und das kann die richtige sein, muß aber nicht; in der Hälfte der Fälle habe ich beim Boot also keine Netzwerkverbindung.
Fixen ließe sich das mit udev-Regeln oder mit ifrename, aber wie ich das mache, das muß ich noch lernen.
Oder das automatische Mounten von Datenträgern: da bin ich bisher auf autofs gestoßen, wie ich das richtig konfiguriere, habe ich aber auf die Schnelle nicht kapiert. Vielleicht gibt es auch elegantere und/oder leichter konfigurierbare Tools dafür.

Es ist echt noch viel zu tun, bis das ein einsatzfähiges System ist, aber das eilt ja nicht. Was ich mit dem kaputten LMDE mache, da bin ich noch nicht ganz schlüssig; ich denke, ich werde einfach versuchen, das neu zu installieren und wenn es dann nicht stabil läuft, wird es durch ein Lubuntu oder ein Xubuntu ersetzt.

2 Kommentare

  1. Geschrieben am 30. April 2012 um 20:09 | Permalink

    Hast Du bereits probiert, die defekte Netzwerkkarte des Boards im BIOS zu entschärfen? Vielleicht hat eine neue BIOS-Version den Netzwerkkarteentschärfenknopf™. 🙂

    Lg Heidi

  2. ryuu
    Geschrieben am 30. April 2012 um 20:25 | Permalink

    Hmmm… An ein BIOS-Update traue ich mich noch nicht ran (wäre vielleicht mal ein lernenswerter Skill… obwohl ich auch nicht glaube, daß es für ein derart olles Mainboard noch neue Firmware gibt). Aber bei einem der nächsten Boots wühle ich mal in den Optionen. Note to self: Notieren, welche Hardware welche ist. Danke für den Tip!